using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"public\sfunction\sset(.*[(])(?!\?)(?'type'string|int|array|float)";
string substitution = @"public function set$1?$2";
string input = @"public function setFirstName(?string $firstName)
public function setLastName(string $lastName)
public function setAge(int $age)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}