import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public\\sfunction\\sset(.*[(])(?!\\?)(?'type'string|int|array|float)";
final String string = "public function setFirstName(?string $firstName) \n\n"
+ "public function setLastName(string $lastName)\n\n"
+ "public function setAge(int $age)";
final String subst = "public function set$1?$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}