$re = '/public\sfunction\sset(.*[(])(?!\?)(?\'type\'string|int|array|float)/m';
$str = 'public function setFirstName(?string $firstName)
public function setLastName(string $lastName)
public function setAge(int $age)';
$subst = "public function set$1?$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;