const regex = /public\sfunction\sset(.*[(])(?!\?)(?'type'string|int|array|float)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('public\\sfunction\\sset(.*[(])(?!\\?)(?\'type\'string|int|array|float)', 'gm')
const str = `public function setFirstName(?string \$firstName)
public function setLastName(string \$lastName)
public function setAge(int \$age)`;
const subst = `public function set$1?$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);