use strict;
my $str = 'public function setFirstName(?string $firstName)
public function setLastName(string $lastName)
public function setAge(int $age)';
my $regex = qr/public\sfunction\sset(.*[(])(?!\?)(?'type'string|int|array|float)/mp;
my $subst = 'public function set$1?$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";