#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^((?!\.jpg$|\.png$|\.js$|\.css$).)*$"
Local $sString = "https://asfasdf.com/xxx/123" & @CRLF & _
"https://asfasdf.com/xxx/123.jpg" & @CRLF & _
"https://asfasdf.com/xxx/123.png" & @CRLF & _
"https://asfasdf.com/xxx/123.css" & @CRLF & _
"https://asfasdf.com/xxx/123.CSs" & @CRLF & _
"https://asfasdf.com/xxx/123.js" & @CRLF & _
"https://asfasdf.com/xxx/123.html"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")