$re = '/^((?!\.jpg$|\.png$|\.js$|\.css$).)*$/mi';
$str = 'https://asfasdf.com/xxx/123
https://asfasdf.com/xxx/123.jpg
https://asfasdf.com/xxx/123.png
https://asfasdf.com/xxx/123.css
https://asfasdf.com/xxx/123.CSs
https://asfasdf.com/xxx/123.js
https://asfasdf.com/xxx/123.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);