re = /^((?!\.jpg$|\.png$|\.js$|\.css$).)*$/mi
str = 'https://asfasdf.com/xxx/123
https://asfasdf.com/xxx/123.jpg
https://asfasdf.com/xxx/123.png
https://asfasdf.com/xxx/123.css
https://asfasdf.com/xxx/123.CSs
https://asfasdf.com/xxx/123.js
https://asfasdf.com/xxx/123.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end