import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!\\.jpg$|\\.png$|\\.js$|\\.css$).)*$";
final String string = "https://asfasdf.com/xxx/123\n"
+ "https://asfasdf.com/xxx/123.jpg\n"
+ "https://asfasdf.com/xxx/123.png\n"
+ "https://asfasdf.com/xxx/123.css\n"
+ "https://asfasdf.com/xxx/123.CSs\n"
+ "https://asfasdf.com/xxx/123.js\n"
+ "https://asfasdf.com/xxx/123.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}