import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\d+\\:\\d+\\:\\d+\\s(INFO|WARN|ERROR)\\]\\:\\s";
final String string = "Feb 08 17:14:35 [16:14:35 INFO]: [Vault] No new version available\n"
+ "Feb 08 19:42:41 [18:42:41 INFO]: CONSOLE issued server command: /help\n"
+ "Feb 08 19:42:41 [18:42:41 INFO]: To view help from the console, type '?'.\n"
+ "Feb 08 19:42:55 [18:42:55 INFO]: -------------------- Help --------------------";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}