// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\d+\:\d+\:\d+\s(INFO|WARN|ERROR)\]\:\s").unwrap();
let string = "Feb 08 17:14:35 [16:14:35 INFO]: [Vault] No new version available
Feb 08 19:42:41 [18:42:41 INFO]: CONSOLE issued server command: /help
Feb 08 19:42:41 [18:42:41 INFO]: To view help from the console, type '?'.
Feb 08 19:42:55 [18:42:55 INFO]: -------------------- Help --------------------";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}