re = /\[\d+\:\d+\:\d+\s(INFO|WARN|ERROR)\]\:\s/m
str = 'Feb 08 17:14:35 [16:14:35 INFO]: [Vault] No new version available
Feb 08 19:42:41 [18:42:41 INFO]: CONSOLE issued server command: /help
Feb 08 19:42:41 [18:42:41 INFO]: To view help from the console, type \'?\'.
Feb 08 19:42:55 [18:42:55 INFO]: -------------------- Help --------------------'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end