const regex = /\[\d+\:\d+\:\d+\s(INFO|WARN|ERROR)\]\:\s/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\d+\\:\\d+\\:\\d+\\s(INFO|WARN|ERROR)\\]\\:\\s', 'gm')
const str = `Feb 08 17:14:35 [16:14:35 INFO]: [Vault] No new version available
Feb 08 19:42:41 [18:42:41 INFO]: CONSOLE issued server command: /help
Feb 08 19:42:41 [18:42:41 INFO]: To view help from the console, type '?'.
Feb 08 19:42:55 [18:42:55 INFO]: -------------------- Help --------------------`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}