package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`lol|<[^>]*>(*SKIP)(*F)`)
var str = `
lol
<img alt="text lol text" />
lol`
var substitution = "***"
fmt.Println(re.ReplaceAllString(str, substitution))
}