use strict;
my $str = '
lol
<img alt="text lol text" />
lol';
my $regex = qr/lol|<[^>]*>(*SKIP)(*F)/p;
my $subst = '***';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";