$re = '/lol|<[^>]*>(*SKIP)(*F)/';
$str = '
lol
<img alt="text lol text" />
lol';
$subst = "***";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;