re = /lol|<[^>]*>(*SKIP)(*F)/
str = '
lol
<img alt="text lol text" />
lol'
subst = '***'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result