const regex = /lol|<[^>]*>(*SKIP)(*F)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('lol|<[^>]*>(*SKIP)(*F)', 'g')
const str = `
lol
<img alt="text lol text" />
lol`;
const subst = `***`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);