package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?miU)On\s[a-z]{3},\s[0-9]{1,2}\s[a-z]{3,4}\s[0-9]{4}\sat\s[0-9]{1,2}:[0-9]{1,2},\s[^<]*<[a-z0-9._%+\-]+@[a-z0-9.\-]+\.[a-z]{2,6}>\swrote:`)
var str = `On Thu, 4 Oct 2018 at 10:48, The Rounds <no-reply+dev@therounds.com> wrote:
On Sun, 23 Sept 2018 at 09:01, Some Person <cool_guy-123+extra@a.co.uk> wrote:
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}