const regex = new RegExp('On\\s[a-z]{3},\\s[0-9]{1,2}\\s[a-z]{3,4}\\s[0-9]{4}\\sat\\s[0-9]{1,2}:[0-9]{1,2},\\s[^<]*<[a-z0-9._%+\\-]+@[a-z0-9.\\-]+\\.[a-z]{2,6}>\\swrote:', 'gmi')
const str = `On Thu, 4 Oct 2018 at 10:48, The Rounds <no-reply+dev@therounds.com> wrote:
On Sun, 23 Sept 2018 at 09:01, Some Person <cool_guy-123+extra@a.co.uk> wrote:
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}