import re
regex = re.compile(r"On\s[a-z]{3},\s[0-9]{1,2}\s[a-z]{3,4}\s[0-9]{4}\sat\s[0-9]{1,2}:[0-9]{1,2},\s[^<]*<[a-z0-9._%+\-]+@[a-z0-9.\-]+\.[a-z]{2,6}>\swrote:", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("On Thu, 4 Oct 2018 at 10:48, The Rounds <no-reply+dev@therounds.com> wrote:\n"
"On Sun, 23 Sept 2018 at 09:01, Some Person <cool_guy-123+extra@a.co.uk> wrote:\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")