// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?miU)On\s[a-z]{3},\s[0-9]{1,2}\s[a-z]{3,4}\s[0-9]{4}\sat\s[0-9]{1,2}:[0-9]{1,2},\s[^<]*<[a-z0-9._%+\-]+@[a-z0-9.\-]+\.[a-z]{2,6}>\swrote:").unwrap();
let string = "On Thu, 4 Oct 2018 at 10:48, The Rounds <no-reply+dev@therounds.com> wrote:
On Sun, 23 Sept 2018 at 09:01, Some Person <cool_guy-123+extra@a.co.uk> wrote:
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}