import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "On\\s[a-z]{3},\\s[0-9]{1,2}\\s[a-z]{3,4}\\s[0-9]{4}\\sat\\s[0-9]{1,2}:[0-9]{1,2},\\s[^<]*<[a-z0-9._%+\\-]+@[a-z0-9.\\-]+\\.[a-z]{2,6}>\\swrote:";
final String string = "On Thu, 4 Oct 2018 at 10:48, The Rounds <no-reply+dev@therounds.com> wrote:\n"
+ "On Sun, 23 Sept 2018 at 09:01, Some Person <cool_guy-123+extra@a.co.uk> wrote:\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CHARACTER_CLASS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}