#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\[\[(.*)\] \[(.*)\]\]"
Local $sString = "This is a link [[https://example.com] [Example]] and [[https://another.com] [Another]]"
Local $sSubst = "$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)