re = /\[\[(.*)\] \[(.*)\]\]/m
str = 'This is a link [[https://example.com] [Example]] and [[https://another.com] [Another]]'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result