const regex = /\[\[(.*)\] \[(.*)\]\]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[\\[(.*)\\] \\[(.*)\\]\\]', 'gm')
const str = `This is a link [[https://example.com] [Example]] and [[https://another.com] [Another]]`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);