// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\[\[(.*)\] \[(.*)\]\]").unwrap();
let string = "This is a link [[https://example.com] [Example]] and [[https://another.com] [Another]]";
let substitution = "$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}