package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\[\[(.*)\] \[(.*)\]\]`)
var str = `This is a link [[https://example.com] [Example]] and [[https://another.com] [Another]]`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}