using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[\[(.*)\] \[(.*)\]\]";
string substitution = @"$2";
string input = @"This is a link [[https://example.com] [Example]] and [[https://another.com] [Another]]";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}