#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<!\d)\d{3}(?!\d)"
Local $sString = "a 123 234 b" & @CRLF & _
" - Has to match 123 and 234" & @CRLF & _
"a 123_234 b" & @CRLF & _
" - Has to match 123 and 234" & @CRLF & _
"aa123 234 b" & @CRLF & _
" - Has to match 123 and 234" & @CRLF & _
"a0123 234 b" & @CRLF & _
" - Has to match only 234" & @CRLF & _
"123a234 b" & @CRLF & _
" - Has to match 123 and 234" & @CRLF & _
"a 123 234" & @CRLF & _
" - Has to match 123 and 234"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")