import re
regex = re.compile(r"(?<!\d)\d{3}(?!\d)")
test_str = ("a 123 234 b\n"
" - Has to match 123 and 234\n"
"a 123_234 b\n"
" - Has to match 123 and 234\n"
"aa123 234 b\n"
" - Has to match 123 and 234\n"
"a0123 234 b\n"
" - Has to match only 234\n"
"123a234 b\n"
" - Has to match 123 and 234\n"
"a 123 234\n"
" - Has to match 123 and 234")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")