import Foundation
let pattern = #"(?<!\d)\d{3}(?!\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
a 123 234 b
- Has to match 123 and 234
a 123_234 b
- Has to match 123 and 234
aa123 234 b
- Has to match 123 and 234
a0123 234 b
- Has to match only 234
123a234 b
- Has to match 123 and 234
a 123 234
- Has to match 123 and 234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)