import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\d)\\d{3}(?!\\d)";
final String string = "a 123 234 b\n"
+ " - Has to match 123 and 234\n"
+ "a 123_234 b\n"
+ " - Has to match 123 and 234\n"
+ "aa123 234 b\n"
+ " - Has to match 123 and 234\n"
+ "a0123 234 b\n"
+ " - Has to match only 234\n"
+ "123a234 b\n"
+ " - Has to match 123 and 234\n"
+ "a 123 234\n"
+ " - Has to match 123 and 234";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}