re = /(?<!\d)\d{3}(?!\d)/
str = 'a 123 234 b
- Has to match 123 and 234
a 123_234 b
- Has to match 123 and 234
aa123 234 b
- Has to match 123 and 234
a0123 234 b
- Has to match only 234
123a234 b
- Has to match 123 and 234
a 123 234
- Has to match 123 and 234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end