const regex = /Candidate name:\s*(Dr.|Mr.|Mrs.|Ms.)?\K.*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Candidate name:\\s*(Dr.|Mr.|Mrs.|Ms.)?\\K.*', 'gm')
const str = `Candidate name:No Space
Candidate name: Madonna
Candidate name: John Smith
Candidate name: John Jacob Jingelheimer Schmidt
Candidate name: Dr. Viktor Frankenstein
Candidate name: Mr. Magoo
Candidate name: Mrs. Doubtfire
Candidate name: Dashy Hasa-Dasherson
Candidate name: Anne-Marie Hasadasher
Candidate name: Apostrophe O'Donnell
Candidate name: 尹希
Candidate name: 益川 敏英
Candidate name: Erwin Schrödinger`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}