import Foundation
let pattern = #"Candidate name:\s*(Dr.|Mr.|Mrs.|Ms.)?\K.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Candidate name:No Space
Candidate name: Madonna
Candidate name: John Smith
Candidate name: John Jacob Jingelheimer Schmidt
Candidate name: Dr. Viktor Frankenstein
Candidate name: Mr. Magoo
Candidate name: Mrs. Doubtfire
Candidate name: Dashy Hasa-Dasherson
Candidate name: Anne-Marie Hasadasher
Candidate name: Apostrophe O'Donnell
Candidate name: 尹希
Candidate name: 益川 敏英
Candidate name: Erwin Schrödinger
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)