import re
regex = re.compile(r"Candidate name:\s*(Dr.|Mr.|Mrs.|Ms.)?\K.*", flags=re.MULTILINE)
test_str = ("Candidate name:No Space\n"
"Candidate name: Madonna\n"
"Candidate name: John Smith\n"
"Candidate name: John Jacob Jingelheimer Schmidt\n"
"Candidate name: Dr. Viktor Frankenstein\n"
"Candidate name: Mr. Magoo\n"
"Candidate name: Mrs. Doubtfire\n"
"Candidate name: Dashy Hasa-Dasherson\n"
"Candidate name: Anne-Marie Hasadasher\n"
"Candidate name: Apostrophe O'Donnell\n"
"Candidate name: 尹希\n"
"Candidate name: 益川 敏英\n"
"Candidate name: Erwin Schrödinger")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")