use strict;
my $str = 'Candidate name:No Space
Candidate name: Madonna
Candidate name: John Smith
Candidate name: John Jacob Jingelheimer Schmidt
Candidate name: Dr. Viktor Frankenstein
Candidate name: Mr. Magoo
Candidate name: Mrs. Doubtfire
Candidate name: Dashy Hasa-Dasherson
Candidate name: Anne-Marie Hasadasher
Candidate name: Apostrophe O\'Donnell
Candidate name: 尹希
Candidate name: 益川 敏英
Candidate name: Erwin Schrödinger';
my $regex = qr/Candidate name:\s*(Dr.|Mr.|Mrs.|Ms.)?\K.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}