re = /Candidate name:\s*(Dr.|Mr.|Mrs.|Ms.)?\K.*/m
str = 'Candidate name:No Space
Candidate name: Madonna
Candidate name: John Smith
Candidate name: John Jacob Jingelheimer Schmidt
Candidate name: Dr. Viktor Frankenstein
Candidate name: Mr. Magoo
Candidate name: Mrs. Doubtfire
Candidate name: Dashy Hasa-Dasherson
Candidate name: Anne-Marie Hasadasher
Candidate name: Apostrophe O\'Donnell
Candidate name: 尹希
Candidate name: 益川 敏英
Candidate name: Erwin Schrödinger'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end