# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\G(?!^)|\()[^()\s]*\K\s+(?=[^()]*\.md\))/_/gm;t' <<< "[probability space](posts/probability space.md) is ... [Sigma Field](posts/Sigma Field.md)"