use strict;
my $str = '[probability space](posts/probability space.md) is ... [Sigma Field](posts/Sigma Field.md)';
my $regex = qr/(?:\G(?!^)|\()[^()\s]*\K\s+(?=[^()]*\.md\))/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";