$re = '/(?:\G(?!^)|\()[^()\s]*\K\s+(?=[^()]*\.md\))/m';
$str = '[probability space](posts/probability space.md) is ... [Sigma Field](posts/Sigma Field.md)';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;