using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\G(?!^)|\()[^()\s]*\K\s+(?=[^()]*\.md\))";
string substitution = @"_";
string input = @"[probability space](posts/probability space.md) is ... [Sigma Field](posts/Sigma Field.md)";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}