#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:\G(?!^)|\()[^()\s]*\K\s+(?=[^()]*\.md\))"
Local $sString = "[probability space](posts/probability space.md) is ... [Sigma Field](posts/Sigma Field.md)"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)