const regex = /(?:\G(?!^)|\()[^()\s]*\K\s+(?=[^()]*\.md\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\G(?!^)|\\()[^()\\s]*\\K\\s+(?=[^()]*\\.md\\))', 'gm')
const str = `[probability space](posts/probability space.md) is ... [Sigma Field](posts/Sigma Field.md)`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);