#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\r\n]+-flac\r?\n"
Local $sString = "http://6tor.org/torrent/899753/va-deep-dive-80s-pop-2022-mp3" & @CRLF & _
"http://6tor.org/torrent/899752/va-deep-dive-70s-pop-2022-mp3" & @CRLF & _
"http://6tor.org/torrent/899751/puscifer-kollekcija-2-albums-2022-flac" & @CRLF & _
"http://6tor.org/torrent/899749/classless-act-kollekcija-2-albums-2022-flac"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")