import Foundation
let pattern = #"^[^\r\n]+-flac\r?\n"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://6tor.org/torrent/899753/va-deep-dive-80s-pop-2022-mp3
http://6tor.org/torrent/899752/va-deep-dive-70s-pop-2022-mp3
http://6tor.org/torrent/899751/puscifer-kollekcija-2-albums-2022-flac
http://6tor.org/torrent/899749/classless-act-kollekcija-2-albums-2022-flac
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)