// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[^\r\n]+-flac\r?\n").unwrap();
let string = "http://6tor.org/torrent/899753/va-deep-dive-80s-pop-2022-mp3
http://6tor.org/torrent/899752/va-deep-dive-70s-pop-2022-mp3
http://6tor.org/torrent/899751/puscifer-kollekcija-2-albums-2022-flac
http://6tor.org/torrent/899749/classless-act-kollekcija-2-albums-2022-flac";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}