re = /^[^\r\n]+-flac\r?\n/m
str = 'http://6tor.org/torrent/899753/va-deep-dive-80s-pop-2022-mp3
http://6tor.org/torrent/899752/va-deep-dive-70s-pop-2022-mp3
http://6tor.org/torrent/899751/puscifer-kollekcija-2-albums-2022-flac
http://6tor.org/torrent/899749/classless-act-kollekcija-2-albums-2022-flac'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end