use strict;
my $str = 'http://6tor.org/torrent/899753/va-deep-dive-80s-pop-2022-mp3
http://6tor.org/torrent/899752/va-deep-dive-70s-pop-2022-mp3
http://6tor.org/torrent/899751/puscifer-kollekcija-2-albums-2022-flac
http://6tor.org/torrent/899749/classless-act-kollekcija-2-albums-2022-flac';
my $regex = qr/^[^\r\n]+-flac\r?\n/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}